Using a Devo 7 with Furious 320?

Discussion in 'Walkera Furious 320' started by BikeWazowski, Apr 17, 2018.

  1. BikeWazowski
    Offline

    BikeWazowski New Member

    Joined:
    Apr 17, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I recently got a really good deal on a used Furious 320. BUUUUT, it came with a Devo7 that does not appear to have been bound (is that right?) to the Furious 320. The display on the Devo7 read "R 150" so maybe it had been used with a Rodeo 150?

    Is there a way to use this Devo7 with the Furious 320, and if so how? I am VERY new to all of this and ended up with the Furious 320 because the deal was worth rolling the dice on.

    Thanks!

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    Select a New Model slot in the Model menu on the radio.

    Follow the Instructions on how to program the TX from the 320 Quick start Guide.

    Ensure that the 320 RX has been reset. It has a button you need to press and hold while applying the battery. This will clear any fixed ID binding.

    Once it is cleared it should connect for the R 150 model slot as long as the TX does not have a Fixed ID set on that slot.

    The reason it does not bind is one of these 2 choices.
    1. TX and / or Model broken
    2. TX or RX has wrong Fixed ID value.
    Try reading the Devo 7 Manual. Fixed ID. And creating new model.

    DEVO7_EM.pdf

    Cheers
     
  3. BikeWazowski
    Offline

    BikeWazowski New Member

    Joined:
    Apr 17, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Thank you! Just minutes ago I found the Devo 7 manual and have been reading through it. I am at work, so I can't try anything hands on, so its just been research and learning so far.

    The instructions to program the model that are in the 320 quick start are written for the Devo 10. I assume this is ok, and I may just struggle to find the menu options in the Devo 7? I kind of started down that path the day I made this original post, but I got confused and scared lol.

    I will reset the RX to clear any possible fixed ID.

    Would it be better to make a new model slot or use the existing R 150 slot and attempt to change the settings to match per the 320 quick start guide?

    Thanks again!

    EDIT:

    I think I should add that this is the GPS version, is there anything special to do with that?
    It appears that a BNF version of the F320 (non gps) was sold with a Devo 7, but I can't seem to find any manual for it. I suspect that if that manual existed it would make programming the controller much easier for me.
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    Follow the instructions for the Devo 10 for the 320 GPS and you will be fine.

    There is some basic differences between the Devo 10 and 7 programming but easy to translate. Ask for help if you need it.

    You may have to swap some things around if you want to manually adjust the tilt servo. you only have one knob on the Devo 7.
     

Share This Page