Unwanted IOC

Discussion in 'Walkera QRX350/QRX 350 Pro/QRX 350 Premium' started by Matt entrican, Feb 20, 2017.

Tags:
  1. Matt entrican
    Offline

    Matt entrican New Member

    Joined:
    Feb 11, 2017
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +1 / 0
    Cheers all. I have a 350 pro V2 with devo f7 rx and upgraded to tx705 from tx703a. When i have no camera on it flys perfectly. When i mount g2d gimbal and ilook camera IOC Mode is engaged and will not fly without ioc mode on. I do not use ioc and would like to disable it and this may solve my problem. I hwve tried using other cameras and every one has caused different probs with flight control. Even stand alone cams. , not wired to my bird cause problems. Can i disable ioc all together or does anybody know of this problem. Thqnk you in advance for any help. Getting quite frustrated.

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    You have to disable the IOC switch in the Devo F7 Set up. You have mixed up the Model -> Device Output menu.
     
  3. Matt entrican
    Offline

    Matt entrican New Member

    Joined:
    Feb 11, 2017
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +1 / 0
    So, ioc CAN be disabled in the f7? Just by disabling it in the tx?
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    IOC is a toggle switch that outputs on a channel it will be in your user manual for the drone.

    You have to program the TX correctly. Also make sure it is not programmed as a helicopter. This is the default.
     
  5. Matt entrican
    Offline

    Matt entrican New Member

    Joined:
    Feb 11, 2017
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +1 / 0
    Ok. Ank thank you very much. But now my issue is this. When i disable ioc, which is aux2 by default. I can no longer pitch my gimbal, which is aux 2 kb on my rx. I tried a prog mix but i cant master aux 2 to slave aux 2 kb. See in my f/c my default for ioc is aux2 but on my rx aux 2 is my pitch for my gimbal. Does make any sense to you? Am i missing something simple?
     
  6. papisp
    Offline

    papisp New Member

    Joined:
    Feb 21, 2017
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I had the same problem and it worked for a long time to AUX2 can not hook up g-2d
    correct configuration:

    INPUT
    FMSW-FMD
    FMTRM-FMOD

    OUPUT
    GEAR-MIX = RTL and HOLD
    FLAP-AUX2 connect pit in g-2d for AUX1
    AUX2-GEAR Remonte camera connect AUX2

    This is the configuration for DEVO 7 and RX703a for DEVO F7 should likewise be
    Regards
     
    Last edited: Feb 21, 2017
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    The Devo F7 radio does not have enough Channels to operate everything you want.

    AUX2 is IOC mode and it is being received by the FC via the PPM interface.

    You have the Gimbal connected to the same AUX2 channel via the PWM output.

    So both are in parallel.

    You need to work out what functionality you want and map it to the 7 available channels.

    With a RX703A and a gimbal you really need the F12E radio. The FC RX703A that you installed requires more that 7 channels, it has additional functionality that is programmed into the lower AUX channels like IOC.

    Cheers
     
  8. papisp
    Offline

    papisp New Member

    Joined:
    Feb 21, 2017
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi so I wrote a long time looking for solutions and through trial and error I came to success. I tested and everything works. Equipment qr x350pro devo 7 RX703a
     
  9. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,272
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    Good you are making use of the available 7 Channels of the Devo F7.

    Cheers
     
  10. papisp
    Offline

    papisp New Member

    Joined:
    Feb 21, 2017
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    IOC could turn off before mounting the gimbal g-2d later I installed a Gimbal plugged it into Aux2 and from then IOC was on all the time I could not turn it off



    In my too, so long conducted tests before disconnecting the cables from Aux2 where he was attached g-2d IOC managed to turn off. Further work and tests have allowed to run Gimbal remote control camera, HOLD and RTL
     

Share This Page

Search tags for this page

ioc qrx350 devo f7