Tali h500 battery problem

Discussion in 'Walkera TALI H500' started by Rani1982, May 18, 2015.

  1. Rani1982
    Offline

    Rani1982 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I'm having a weird problem with my h500 battery.
    I place it in the tali h500 and the battery is OFF, and my h500 starts anyway.
    Please let me know if my battery is not good or is the problem with the tali h500

     
  2. Buzztronic
    Offline

    Buzztronic Member

    Joined:
    Apr 25, 2015
    Messages:
    41
    Likes Received:
    4
    Trophy Points:
    8
    Ratings:
    +4 / 0
    I've not heard or had that problem before Rani. Have you tried pressing the triangle button?

    Taking it apart via the shell-removal may reveal the problem?

    How new is your Tali?

    This is how I remove the shell:

     
  3. Rani1982
    Offline

    Rani1982 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I have it for about 2 months
    it doesn't matter if the battery is on or off, as soon as i plug it in the tali gets on.
    this weird problem started after a soft crash and the battery was disconnected from the tali.
    iv'e opened the battery and the tali but everything seems to be ok
     
  4. Buzztronic
    Offline

    Buzztronic Member

    Joined:
    Apr 25, 2015
    Messages:
    41
    Likes Received:
    4
    Trophy Points:
    8
    Ratings:
    +4 / 0
    You need to take your TALI H500 like the video shows to examine the control board and see if anything is out of place.
     
  5. Rani1982
    Offline

    Rani1982 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Take it where?
    Do you have a place where I can send it so they can examine it? Because in my country there is no place that I can fix it
     
  6. DivenParker
    Offline

    DivenParker New Member

    Joined:
    Sep 20, 2016
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +1 / 0
    Check your Tali h500 and be sure it is Ok, and then replace a new FPV battery, if everything goes well, it means your it is your battery's problem.
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,374
    Likes Received:
    354
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +456 / 14
    It sounds like the power up electronics inside the smart battery has failed.

    Replace the battery.

    Cheers
     
    • Like Like x 1

Share This Page

Search tags for this page

batteri till tali h500

,

how can i tell that my tali h500 battery is full

,

how to discharge a walkera tali h500 battery

,

problem med walkera tali h500

,

tali h500 battery

,

tali h500 error log

,

tali h500 telemetry

,

walkera h500 droun battery