Runner 250 PRO latency in throttle control

Discussion in 'Walkera Runner 250 Pro' started by eddyburg, Mar 31, 2020.

  1. eddyburg
    Offline

    eddyburg New Member

    Joined:
    Mar 29, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brussels, Belgium
    Ratings:
    +0 / 0
    Hi all,

    I read a lot of things on this forum but I did not find a solution to my problem. Maybe you can help me?

    In flight, I have big latencies / lags with the throttle control (the rest is ok). When I push throttle forward, the quad takes time to react.
    My batteries are new and fully charged every time, but have the impression that the quad never goes 100%.
    Also, when the quad is on the ground, without the props, and I push throttle forward, at the noise I hear jolts.

    For me I have a loss of power on one or more engines but I don't know much about it. Is this possible to fix it ?

    Thanks in advance for your advies,

    Edouard

    My english is from Google translate sorry :)

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,978
    Likes Received:
    441
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +566 / 16
    HI Edouard.

    Set you location in your profile so we know what country you are from.

    The throttle is not a throttle control on the 250 Pro when it is in Atti or GPS mode.

    It switches to become a ascend rate and descend rate from mid position. It only behaves as a throttle when in manual mode.

    You cannot test the throttle on the ground without the props. The drone is in auto stabilise and it tries to level the drone but without props it cant, so it drives it berserk.

    You are describing the normal behaviour of the 250 Pro.

    Cheers Brian

    Google translate did a good job. The english was fine.
     
  3. eddyburg
    Offline

    eddyburg New Member

    Joined:
    Mar 29, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brussels, Belgium
    Ratings:
    +0 / 0
    Hi Brian,

    Thanks for answering so fast !

    In fact I do not use GPS or Atti mode, only Manual mode (more responsive :)).

    The recurring problem in flight is really the latency of the throttle as well as repeated power losses, with new and charged batteries. When there are power changes, the quad "shakes".

    The quad seems breathless when I make it climb, and that even at the start of the flight.

    A problem with the FC?

    Cheers,

    Edouard
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,978
    Likes Received:
    441
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +566 / 16
    Sounds more like a problem with the props. Make sure that there are no nicks etc on the props.

    have you crashed the drone at all?
     

Share This Page