Rodeo 150 Motor trouble..

Discussion in 'Walkera Rodeo 150' started by Heebus, Oct 3, 2016.

  1. Heebus
    Offline

    Heebus New Member

    Joined:
    Oct 2, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I posted in bugs and issues, but getting no response, sorry for the double post..

    I have an issue with the front left ( when drone is pointed away from u) motor. It seems when they're warmed up, the motor kicks down, or seems to have trouble like its being slightly blocked or a little friction to it. It kicks in and out, not constant, but sometimes I have to land and disengage re ingage the motors. If I hover slightly of the ground it doesnt do it, and same if I hold on to it and give it full throttle, it just seem to be when its warm and around 50-60% throttle. You can actually here it and see the drone slightly dip in that direction when the trouble starts. A friend has suggested to me that it might be a bad solider on the esc board. does that sound like the case, and is it an easy fix? I dont want to send it back as it too a long while to get it, and dont wann have a ton of down time

    thanx
    Heebus
     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    4,329
    Likes Received:
    265
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +346 / 12
    Swap the motor to the opposite corner and see if the problem moves with it.
     
  3. Heebus
    Offline

    Heebus New Member

    Joined:
    Oct 2, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    No need now, it just caught on fire, owned it since sept 8, took 2 weeks to get in mail, came with faulty charger, waited for charger replacement, now this 20161004_151506.jpg 20161004_151502.jpg
     
  4. iskandar
    Offline

    iskandar Active Member

    Joined:
    Oct 13, 2016
    Messages:
    320
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Kuala Lumpur
    Ratings:
    +54 / 0
    Is it still under warranty? Go and swap it for a F210 3D, ;).
     
  5. dascrow
    Offline

    dascrow Administrator Staff Member

    Joined:
    Aug 12, 2014
    Messages:
    129
    Likes Received:
    8
    Trophy Points:
    18
    Ratings:
    +8 / 0
    wow, that's crazy. Did it catch on fire during flight?
     
  6. IWannaGoFast
    Offline

    IWannaGoFast New Member

    Joined:
    Nov 2, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Same thing is happening to me but it's the back left motor/esc.
     
  7. leoncini
    Offline

    leoncini New Member

    Joined:
    Jan 19, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I'm having the same issue and the worst part is that drone have less than ten flights!. The problem looks like a bearing in one of the motors but so far I haven't able to figure out which one. Is very disappoint to have that kind of problem with a new quad.
     

Share This Page