Rodeo 150 driver issue

Discussion in 'Walkera Help!' started by Adam Kirk, Aug 30, 2018.

  1. Adam Kirk
    Offline

    Adam Kirk New Member

    Joined:
    Aug 30, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi, when i connect my rodeo 150 to my win 10 pc the drivers do not install. i get error message: driver discriptor request failed, then port failed. the drivers do not exist on the walkera website. please help with how to install my drivers. I am experienced with beta flight and build your own quads, but this is really confusing me.

     
  2. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    The driver is installed as part of the Chrome Betaflight or Cleanflight installation process. Be advised that the 150 is not compatible with later versions of these products.

    Cheers
     
  3. Adam Kirk
    Offline

    Adam Kirk New Member

    Joined:
    Aug 30, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi, thanks for the reply, the usb drivers are not with these apps, clean flight1.2.0, and i dont think it will work with beta flight. my message of the failed port and descriptor i get from device manager. the trusted error43. so i could do with some more guidance or be directed to the usb driver for the fc so i can force my pc to read the fc. many thanks
     
  4. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13

Share This Page