Re-pairing Devo 7 to 210 3d after disassembly?

Discussion in 'Walkera F210 3D' started by sweyant, Oct 28, 2017.

  1. sweyant
    Offline

    sweyant New Member

    Joined:
    Nov 30, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I just had to replace a whole bunch of plastic bits for my 3D as a result of numerous smallish crashes. It was flying before I took it apart. Ended up replacing the power board due to broken connections. Got her all back together and it powers up fine but will not pair with my Devo 7. I tried all combinations of power on drone, then turn on Devo, reverse of that, etc. I even pushed the little reset button on bottom of the drone.
    Is there something else i should do to get it to pair again? I have taken tiny little screws out and back in and out so many times that I am almost ready to give up. I found that I have stripped out 2 allen heads that are holding the upper carbon fiber cover over the circuit boards and so can not take it back apart again. Unless someone has a way I can get it to pair that does not involve disassembly again, I will have to put this little hobby on the shelf until I can afford to get a new one.

     
  2. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,207
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    You have not reassembled the drone correctly. Check the mounting of the RX and FC and the ribbon cables. You may have damaged the ribbon.
     

Share This Page