Problems

Discussion in 'Walkera Help!' started by maxi1906, Jan 8, 2017.

  1. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    Hello all, I had a not so bad crash a while ago where the drone fell from about 1.5 metres flat on its back. After that one motor was not spinning up, at all. So I pulled it completely apart and looked at the pdb, the connector was broken as it turns out. So I replaced it with the upgraded pdb. Then when I was testing it, it fell straight out of the sky as soon as I put it up to full throttle. I thought that was weird so I swapped the esc's around and it did the same thing except this time 1 motor kept spinning, even after I disarmed them. I can give you more details if you think you can help me. Thanks.
     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    2,587
    Likes Received:
    142
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +182 / 9
    We would need a lot more details. You have not even told us what the drone is?
     
    • Like Like x 1
  3. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    Sorry, It is an f210 non-3D. When it falls from the sky, it always falls back to the right, regardless of whether the esc's have been swapped or not. Sometimes, a few of the motors/esc's restart. I did a test a few days ago where I tried to take off with it on advanced mode and as soon as it took off it rolled to the right and slammed into the ground. Thanks, please tell me what else you need to know, I have *some* flight footage but it's not the best.
     
  4. iskandar
    Offline

    iskandar Member

    Joined:
    Oct 13, 2016
    Messages:
    200
    Likes Received:
    19
    Trophy Points:
    18
    Location:
    Kuala Lumpur
    Ratings:
    +28 / 0
    Are you sure using right prop on each motor?
     
    • Like Like x 1
  5. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    Yes, ccw on ccw and cw on cw

    Sent from my Nexus 6P using Tapatalk
     
  6. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    I checked and double checked the esc's as well
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    2,587
    Likes Received:
    142
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +182 / 9
    Try checking the FC ribbon connector. Clean with isopropyl alcohol and replace.
     
    • Like Like x 1
  8. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    Ok thanks for your help. Where would the best place to get a replacement ribbon, because I think the best thing to do is to replace it. But if you think I should clean it I will.
     
  9. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    2,587
    Likes Received:
    142
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +182 / 9
    Given that you have not filled out your location details in your profile I cannot recommend a purchase location. Search the web using the part number. The parts are in the stickies in the 210 forum.
     
  10. maxi1906
    Offline

    maxi1906 New Member

    Joined:
    Jan 7, 2017
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Queenland, Australia
    Ratings:
    +1 / 0
    I'm in Australia

    Sent from my Nexus 6P using Tapatalk
     

Share This Page