Possible issues with my ilook+ camera.

Discussion in 'Walkera Help!' started by savage600, Apr 10, 2018.

  1. savage600
    Offline

    savage600 New Member

    Joined:
    Apr 10, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi guys, I am new to this forum, so please excuse me if this is in the wrong place.

    I have recently installed and have working a Walkera G-3DH 3 axis Gimbal ( newly purchased ) ad I have installed into that, a Walkera ilook+ camera which I have had for a while but never used.

    I have the Gimbal working perfectly and running through my X8R and My Taranis XD9 Plus tx and rx. The flight controller on my H550 is a Genuine Pixhawk Flight Controller.

    I have connected the selected Channel 8 for the dip switch settings ( as per the ilook+ HD manual ) as the ilook+ manual didn't have the numbers for that channel . I have an immersion duo 5800v1 receiver set to the same number of 5733, but when I power the camera, there is no video picture show on my monitor and the light of the front of the camera is solid red, that might flash a couple of times when first powered.

    I can press the button on top of the camera but this does nothing and I have a micro sd card installed.

    Am I doing something wrong here, or what can I do to get video signal? Is there any plugs, leeds etc that I need to get to program or update the camera?

    Thanks in advance,

    Cheers Dave.

     
  2. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    So you have the VRX set to Band B channel 1? 5733Mhz.

    What monitor do you have connected to the VRX. Is the monitor connected correctly?

    Did you ever power up the Ilook without the Antenna connected? This will destroy the Ilook VTX.
     
    • Like Like x 1
  3. savage600
    Offline

    savage600 New Member

    Joined:
    Apr 10, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hey mate, I have had the ilook + for a while now and got it in a box of stuff and haven't used it. I personally have not powered it, as I have other fpv stuff and know that this is a no no, but in saying that, I don't know whether the previous owner did or didn't.

    In terms of a Monitor, I have a Field View 888 and for the Rx, it is an Immersion Duo 5800V4.1 Race edition and although I run RHCP Antennas and the Walkera has LHCP, I got a couple of LHCP antennas to test. I know the Monitor and Duo5800v4.1 works and is setup properly as that is what I use on my other Multirotors.

    In terms of what Channel it is set to, I don't have the channel numbers in the ilook + manual, but went of off the ilook + HD manual and used channel 8 frequency 5733 ( which it is on now ) and tired a couple of the others of the even channels 2,4,6,8 as I read that the ilook+ can only used those frequencies.

    I have formatted the micro sd card and inserted it prior to powering up, but all I get from the camera is the light stays on and does not go off after saying it is initialised or in standby mode and I don't receive any camera feed on my monitor.

    Is there a way of trying to update the firmware and see if this makes a difference?

    Cheers Dave.
     
  4. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    Ok,

    All what you say is correct. You have selected the correct Channels and bands both ends. RHCP and LHCP mismatch will reduce range but not stop video.

    So all that is left is.

    1) Remove SD card and power up camera. SD card issues like too large a card has been known to prevent Camera booting up correctly.

    2) Ensure card is 32Gbyte or Smaller and format it again. Create a folder called DCIM on the card.

    3) The ILook does have a FW update to make the screen size compatible with the F12E Transmitter. From memory I think you need the UP02 tool to do the upgrade. I will have to search through my notes on this as I upgraded mine a long long time ago.

    Cheers

    I all the above fails I guess the ilook is broken. You could try an alternate antenna on the camera. But that is a Hail Mary pass.
     
    • Like Like x 1
  5. savage600
    Offline

    savage600 New Member

    Joined:
    Apr 10, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hey mate, it appears that the Ilook+ is shagged. The memory card was only a 2 gig ( just a spare I had around the place and I formatted it again and created the DCIM folder), I powered it with and without the card and no difference.

    I have had the camera for maybe 2 years, but have never used it. Id does have a nice ding in the metal case, so maybe he had dropped it and it stuffed up somehow.

    I downloaded the firmware update, put it on the micro sd card, extracted it and inserted it into the camera and it seemed to load it and the red light on the front blinked as it should.

    When the camera is powered the red light just stays on, but occasionally it dims on lower and then back to the original brightness. It does this on and off .

    I may have to look for another one of these cameras, as I bought the Gimbal for it now and having the vtx in there was handy, but there isn't a lot of room in there and it gets warm.

    Whats gets me though, it doesn't seem to even take a pic or shorts of a vid, let alone picture to a monitor.

    Thanks for your help dude,

    Cheers Dave.
     
  6. bjr981s
    Online

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    I agree. If it has a ding in it I would think has been in a crash.

    Walkera were selling the iLook + HD for less than half price of an iLook. I bought a couple. I looked for the link to post for you but it has gone.

    You an also use these. They are a direct replacement.

    Quanum FPVplus Wide-Angle 1080P HD FPV Camera with 5.8GHz Transmitter

    But hard to find.


    Sorry.
     

Share This Page