Please help!!

Discussion in 'Walkera Help!' started by Peter Hernandez, Nov 11, 2019.

  1. Peter Hernandez
    Offline

    Peter Hernandez New Member

    Joined:
    Nov 11, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    So I just bought a walkera Runner 250 from someone. When I got it, I tried to fly it, but it wouldn’t do anything, so I assumed the battery was dead. I plugged in the battery and unplugged it when the light turned green. I then tried to fly again. I turned on the controller, plugged in the battery then waited. The front (white) lights never turned on. But the rear (red) lights turned on solid for a second then started to alternate blinking. Also when I plug the battery in, the drone does not make a beeping noise and does not slightly turn the motors like it’s supposed to. The red lighted continue to alternate blinking for ever. And even when I try to arm the motors, the blinking continues, and the motors do not move at all. And the white light stays off the entire time! I really need help! I know that other people have had this problem, but I really am looking for a way to troubleshoot it to find what the problem is, and I’m not sure if there has been a solution found! Please help

     
    Last edited: Nov 11, 2019
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,756
    Likes Received:
    427
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +540 / 15
    Firstly make sure that you turn on the drone within 3-5 seconds of turning on the remote.

    Try turning on the drone first then the remote. Just to test. Not as normal practice.

    Can you confirm the version of the RUNNER 250? Standard, R, Pro etc

    You need to check the battery first. It may be damaged. Is it the OEM battery or third party?

    Do you have a LiPo checker?
     
  3. Peter Hernandez
    Offline

    Peter Hernandez New Member

    Joined:
    Nov 11, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I have done the turn on thing many times, and usually I turn the drone on within 1-2 seconds after the controller. And I have done the drone first and radio second, and sometimes the red lights blink together, but they don’t do anything else, and it still doesn’t turn the motors or make the beeping noise. And I am quite sure that it is the walkera runner 250 standard. Also the battery is the oem one, and it doesn’t seem damaged, but I’m not sure. And I do not have a lipo checker.
     

Share This Page