No rear leds

Discussion in 'Walkera F210' started by Nate78, Dec 7, 2016.

  1. Nate78
    Offline

    Nate78 New Member

    Joined:
    Nov 26, 2016
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    my drone had developed a fault, the drone is not responding to any direction from the transmitter, the rear LEDs flash once when I attach the battery but nothing else, The transmitter is beeping every second or so,
    I've tried manually binding the two again but no luck,
    Have I missed something ?
     
  2. Koetjeboe91
    Offline

    Koetjeboe91 New Member

    Joined:
    Jul 16, 2016
    Messages:
    28
    Likes Received:
    10
    Trophy Points:
    3
    Location:
    The Netherlands
    Ratings:
    +14 / 1
    Have you tried putting the drone on a level ground before you plug in the battery also check that all switches and knobs are on there normal place?
    does the drone starts beebing like hell after a few sec after the battery is plugged in. if so its indeed a no bind with the transmitter. switch the drone off and the transmitter.
    after that start the transmitter wait 3 to 5 sec before you plug in the drone (give the transmitter time to boot up). if that does not work check if you can see the drone and transmitter in cleanflight.

    ps
    DO NOT UPDATE THE FIRMWARE!
     
  3. iskandar
    Offline

    iskandar Active Member

    Joined:
    Oct 13, 2016
    Messages:
    314
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Kuala Lumpur
    Ratings:
    +54 / 0
    Make sure all toggles are at 0 position too.
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,291
    Likes Received:
    207
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +267 / 9
    What do you mean by this?

    Did you use a fixed ID?
     
  5. Nate78
    Offline

    Nate78 New Member

    Joined:
    Nov 26, 2016
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Thanks for the replies, I decided to take the drone apart and look for any obvious signs of damage or loose connections, the ribbon between the main controller and pcb had a rip in it, I'm guessing that is the reason. Do the 250 and f210 share the same ribbon lead ?
     
  6. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,291
    Likes Received:
    207
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +267 / 9
  7. Nate78
    Offline

    Nate78 New Member

    Joined:
    Nov 26, 2016
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    That was my understanding, I've ordered a couple,
    I must of caught it somehow when looking at and taking out the camera tx, I was flying it earlier in the day with no issues
     
  8. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,291
    Likes Received:
    207
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +267 / 9
    Make sure you replace any props with nicks in them etc. I replace all after a crash regardless. Also balance them.

    Vibration is the enemy. Off balance props with kill the IMU in flight and effect any non rigid part. e.g. the ribbon cables.

    Cheers
     
  9. Nate78
    Offline

    Nate78 New Member

    Joined:
    Nov 26, 2016
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Thanks for the advice
     
  10. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,291
    Likes Received:
    207
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +267 / 9
    Your most Welcome.

    Cheers Brian
     

Share This Page