Newbie question, gyro help?

Discussion in 'Walkera QR X800' started by Snotblossom, Dec 14, 2017.

  1. Snotblossom
    Offline

    Snotblossom New Member

    Joined:
    Dec 14, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi all,
    New here and somewhat new to flying quads. (Kids had several el cheapo quads years ago that i of course had to try) So anyway, I was out for a few test flights with my new X800 and was doing well. Had maybe 90 minutes fly time in and while coming down to land one prop caught a wayward tree branch causing a crash. Already replaced one fixing block and one blade. Everything else seems fine. But now when i try to lift off only the front lifts and it tips backward. Seems to me maybe a gyro problem? Cant seem to find any information on finding a gyro reading or even where its located.
    Secondly, it also wont go into compass calibration. Dont know if this may also be a symptom or part of the problem. Any help appreciated.
    Lastly, I was working on a dragon link upgrade and wondering if this could also be a fix using the full V3 kit with micro osd. Currently have all the parts except waiting for the osd.

     
  2. Snotblossom
    Offline

    Snotblossom New Member

    Joined:
    Dec 14, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    BTW, The receiver is the RX706

    Sent from my SM-N920T using Tapatalk
     
  3. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,208
    Likes Received:
    318
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +415 / 13
    Pull it down and check all wiring connections.
     

Share This Page