Lost all stabilization on F210 ,HELP

Discussion in 'Walkera F210' started by Nameless Droner, Mar 19, 2018.

  1. Nameless Droner
    Offline

    Nameless Droner New Member

    Joined:
    Feb 11, 2018
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    United state
    Ratings:
    +1 / 0
    I’ve only taking my F210 out to fly 3 times. And everything has worked just fine up until today.
    I started to take off and it was pulling to the left so hard that as soon it got 2 inches high the props hit the ground.

    And with the mix switch in 1 , 2 or 3 it’s like it’s stuck in acro mode.

    In order to take off I have to counter correct it pullin to the right and I have 0 stabilization in angle or horizon mode.

    Hopefully someone can tell me what’s up with this.

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,367
    Likes Received:
    352
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +454 / 14
    Check the trims on your radio.

    Also check that you have the correct model config selected.

    Have you connected it to a PC?
     
  3. Nameless Droner
    Offline

    Nameless Droner New Member

    Joined:
    Feb 11, 2018
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    United state
    Ratings:
    +1 / 0
    I have went through all three positions on the mix switch. It’s the same in all three positions.
     
  4. Nameless Droner
    Offline

    Nameless Droner New Member

    Joined:
    Feb 11, 2018
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    United state
    Ratings:
    +1 / 0
    I haven’t hooked it up to clean flight because I’m new at all this and I’m sure I’d probably brick the fc. since I have no experience doing it.
     
  5. Gribz
    Offline

    Gribz New Member

    Joined:
    Jul 22, 2017
    Messages:
    13
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Rotterdam
    Ratings:
    +3 / 0
    Hooking your 210 to cleanflight won't brick your fc. Just don't flash it with different software. When you connect to clean flight you can set your modes. Plus you can see if the switch on your Devo reacts to movements as you can see it switch from positions in de modes tab in clean flight.

    If you are new to cleanflight here is a step by step video to install it. Don't forget to install the cp210x USB to UART bridge driver.



    Hooking it up to cleanflight will help you to pin point the problem you are having with your 210.
     
  6. Gribz
    Offline

    Gribz New Member

    Joined:
    Jul 22, 2017
    Messages:
    13
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Rotterdam
    Ratings:
    +3 / 0
    Forgot to mention:

    If you install Cleanflight then do not install version 2. Install version 1.1.0 or 1.2.1 or 1.2.4
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,367
    Likes Received:
    352
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +454 / 14
    The correct version of Cleanflight for Walkera drones is 1.2.0 It is available in our resources section. 1.2.4 will brick most Walkera FW as 1.2.4 changes the way decimal points are interpreted in the Settings file. 1.2.4 may work with the F215 as this was released post the 1.2.4 cleanflight availability.

    To be safe only use 1.2.0 and only for diagnostics. Do not use any tool to calibrate sensors, throttles or anything else.

    SW:CleanFlight version 1.2.0 F210, F150, F110 Compatible English

    It sounds like you do not have the correct model config on your Devo radio.

    Go to the monitor menu in the Function main menu and see what happens to channels 5,6 and 7 as you throw the allocated switches.

    If these don't change then program the radio as per the Quick start user guide.


    Cheers
     
  8. Gribz
    Offline

    Gribz New Member

    Joined:
    Jul 22, 2017
    Messages:
    13
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Rotterdam
    Ratings:
    +3 / 0
    I run 1.2.4. Smoothly on my F210. Could this be due to the fact I got a new FC a couple of months ago? With my first FC I only could connect to the Chinese version of Cleanflight with the help of that chinglish YouTube video :)
     
  9. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,367
    Likes Received:
    352
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +454 / 14
    If you do a settings load (Included in the Walkera FW update, required in the process ) after the FW upgrade, your model will start flipping.

    There are dozens of users that complain of this particular problem. Walkera do not update FCs so yours is at teh same risk as others. I recommend you use 1.2.0.

    Do a search on the forum don't restrict it to just F210s.

    Cheers Brian
     

Share This Page