Hi everyone newbie here

Discussion in 'Introductions and Site Help' started by Gary Stanfield, Jul 10, 2019.

  1. Gary Stanfield
    Offline

    Gary Stanfield New Member

    Joined:
    Jul 10, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi can anyone help please
    Just bought a sh 83 helli and when I turn it on the servos go mad and 1 even turns all the way round

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,628
    Likes Received:
    410
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +523 / 15
    I take it this was a second hand heli?

    What radio are you using with it?

    Can you take some pics?

    cheers
     
  3. Gary Stanfield
    Offline

    Gary Stanfield New Member

    Joined:
    Jul 10, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Ye second hand walkera wk0 IMG_20190710_163611.jpg IMG_20190710_163611.jpg I703
     

    Attached Files:

  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,628
    Likes Received:
    410
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +523 / 15
    I would say that you have a damaged servo. The one that spins all around. But not sure what servo it is.

    You have the servos plugged into the wrong channels on the RX. Is it a Collective pitch or Fixed pitch. (2 or 3 servos to control the rotor head) I am not sure of the specs of the Heli.

    Can you take a picture of the Heli itself The tail servo and the servos on the rotor head.

    Cheers Brian

    p.s. The servos are easily replaceable as is the Radio and RX.
     
  5. Gary Stanfield
    Offline

    Gary Stanfield New Member

    Joined:
    Jul 10, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Collective pitch.
    3 servos on rota head
    They were all plugged in correctly but the airlaron one on tge right (plugged into aiel) is the one spinning the pitch one on tge other side works correctly (plugged into aux1) I've ordered 3 for the front and the tiny one for the tail. So I'll get them tomorrow and I'll try again lol
    Even with them all off on the bench plugged in the same servo just keeps spinning
     

    Attached Files:

  6. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,628
    Likes Received:
    410
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +523 / 15
    Ok In the picture it showed a servo in the Gear nothing in Ail and nothing in Aux 1.

    You will need a pitch gauge and a swash leveller to re-setup the servos and connecting rods. You will also need a flybar locking tool to set up the flybar.

    Cheers
     

Share This Page