FPV drone with DEVO 7 trouble

Discussion in 'Walkera Help!' started by CasualFPV, May 5, 2018.

  1. CasualFPV
    Offline

    CasualFPV New Member

    Joined:
    May 3, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    So recently I decided I wanted to get into FPV drones, I decided to build my first drone because I knew it would give me the experience and knowledge when I need to fix it down the road. I mostly followed this guide with a few changes I decided to make (parts list below):



    I only changed 2 things about the build, I decided to get the Runcam split 2 and opted for a controller that I thought would feel better to use, the Walkera Devo 7 with the RX601 receiver.

    After building the drone plugged it into the PC and set it up in CleanFlight, everything seemed to be working the channels all respond correctly in CleanFlight but when I unplug the drone from my PC it wont respond to anything, I've searched through countless forum threads and YouTube videos trying to find people who have had the same problem but I cant find a solution, I've also tried setting an arm switch as well as setting a fail-safe switch but nothing I've tried works. Does anyone know how to fix this issue?

    Here's the important parts in my parts list:
    ESC: Racerstar RS20Ax4
    Motors: Racerstar Racing Edition 2205 2300KV 2-4S Brushless Motor
    PTB: Matek Systems PDB-XT60
    Flight Controller: SP F3 Deluxe Acro 10 DOF for FPV Racing Drone
    Walkera DEVO 7 Transmitter
    Walkera RX601 Receiver

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,277
    Likes Received:
    329
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +429 / 13
    When you say all the controls can be seen working in Cleanflight. I assume that you mean from the Devo 7 when you operate the sticks?
     

Share This Page