Fixed Devo 7 transmitter not working with Walkera RX-SBUSe RX with new quad

Discussion in 'Walkera Devention Radios' started by Phil, Dec 9, 2019.

  1. Phil
    Offline

    Phil New Member

    Joined:
    May 14, 2019
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1 / 0
    I just want to share this incase anyone else is having the same issue. I recently purchased a Walkera RX-SBUSe receiver from banggood along with a new quad. I Have a Devo 7 transmitter and had issues getting receiver to talk to Omnibusf4sd flight controller. Transmitter binded fine, just didn't get any stick movement in betaflight. After a couple days tinkering I checked the pin locations on the jts plug to the receiver and flight controller and found the 5v and sbus wires on the reciever side were in the wrong spot. 5v and sbus were swapped. I didn't notice this because even though they were swapped the reciever still powered up. So I pulled the pins and changed according to the wiring diagram and it now works great! Wanted to post this info because I didn't find anything anywhere with this same issue. I'm not bad mouthing Banggood or Walkera or anything. My order arrived in good condition and the product is great. I just hope this might help someone else someday.

     
    • Like Like x 1
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,770
    Likes Received:
    429
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +542 / 16
    Good Post. I have made it a Sticky.
     

Share This Page