F210 3D and FrSKY Taranis X8R

Discussion in 'Walkera F210 3D' started by Serjik, Nov 5, 2016.

  1. Serjik
    Offline

    Serjik New Member

    Joined:
    Oct 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1 / 0
    Hi. I ran into some problems when connect the X8R with 210 3D-Z-09.

    X8R binding with Taranis is OK (green led), but F210 is not connected and does not respond to the sticks.

    What did I do wrong?
    Please help... Thanks for your answer...
     
  2. Serjik
    Offline

    Serjik New Member

    Joined:
    Oct 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1 / 0
    I already do:
    1. 210 3D-Z-09 - change to SBUS mode...

    In Cleanflight:
    2. Ports - UART 2 Serial RX turn ON
    3. Receiver - Receiver Mode change RX_SERIAL
    4. Receiver - Serial Receiver Provider change SBUS

    What's wrong?
     
  3. iskandar
    Offline

    iskandar Active Member

    Joined:
    Oct 13, 2016
    Messages:
    320
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Kuala Lumpur
    Ratings:
    +54 / 0
    I thought we cannot straight away use X8R with F210 3D (will need a converter because it is S.BUS, digital), but we can use D4R-II (PPM, analog) out of the box.

    I'm also interested to know the answer to this.

    Hopefully someone will chime in.
     
    Last edited: Nov 5, 2016
  4. Serjik
    Offline

    Serjik New Member

    Joined:
    Oct 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1 / 0
    Yes... i am used original External Receiver Converter (F210 3D-Z-09). It support SBUS and PPM...
     
    • Like Like x 1
  5. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    4,329
    Likes Received:
    265
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +346 / 12
    Remember that S-Bus is a Futaba standard and has the servo output order as AETR. Walkera is different and uses EATR.

    Make sure you set the model in your FrSky TX to EATR to make it compatible with Walkera.

    You will also need to do this for the PPM or CPPM output.

    Cheers
     
  6. droningon.co
    Offline

    droningon.co New Member

    Joined:
    Nov 8, 2016
    Messages:
    25
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2 / 0
    Did you ever get this working? How did you define the 2D/3D switch?
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    4,329
    Likes Received:
    265
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +346 / 12
    The switches are controlled by values on the channels above 4. It is clearly defined in the user manual for the F210.

    Flap Channel and Gear channel. 6,5

    You need to stop fiddling around with Betaflight and cleanflight incorrect versions. Get the model flying on the standard radio.

    Then start your mods. One step at a time. change and verify, change and verify.

    You will need to change the input to S-Bus in Cleanflight version 1.2.0 First. I assume you are using s-bus not cPPM on the FrSky RX.
    And make sure you get the channels in the correct order.
     
  8. droningon.co
    Offline

    droningon.co New Member

    Joined:
    Nov 8, 2016
    Messages:
    25
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2 / 0
    I'm finally getting to the bottom of it - the Walkera external-RX unit doesn't seem to work properly in SBUS and so I've set it to PPM and now the beeping has stopped and I can successfully arm via the left-rudder command...BUT the motors won't spin :( Any ideas?
     
  9. droningon.co
    Offline

    droningon.co New Member

    Joined:
    Nov 8, 2016
    Messages:
    25
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2 / 0
    Ok...I noticed that 'OneShot' was enabled by default in the latest 0.0.5 firmware, I disabled OneShot and now the motors arm AND spin!!

    Almost there now!!
     
  10. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    4,329
    Likes Received:
    265
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +346 / 12
    The standard signal from the OEM RX to FC is PPM.

    You will get much faster responses using s-bus. if you can get it to work correctly.

    What makes you think this is a one shot issue? If that was the case then all that updated to 0.0.5 would brick their FC.

    What version of Cleanflight are you using?
     

Share This Page

Search tags for this page
f210 beep d4r
,

f210 d4r

,
f210 mode select taranis
,
f210 taranis setup
,
taranis f210
,
walkera 110 bind with frsky