F 210 Problem with Rear right Motor

Discussion in 'Walkera F210' started by dekelsz, Sep 21, 2017.

  1. dekelsz
    Offline

    dekelsz New Member

    Joined:
    Sep 21, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    hi
    after crashing my F 210 ( not too hard ) the right rear stoped working ( not doing anything )
    i tried replacing the ESC with a new one - no result
    i tried replacing the Motor with a new one - no result

    does anyone have any idea what to do ? do you think i should try to connect to cleanflight or try to replace the main board ?

    thank you

    Dekel

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Joined:
    Sep 19, 2015
    Messages:
    5,691
    Likes Received:
    421
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +534 / 15
    Most likely a cracked main board. Don't throw out your old motor or ESC.

    The correct procedure for doing the diagnosis is to swap the Motor and ESC from the opposite corner. The same rotation direction.

    If the fault moves with the ESC or Motor then you know what is faulty. If the fault stays on the arm then the Mainboard is Faulty.

    Cheers

    p.s. Could also be a loose or cracked ribbon cable to the FC or the RX. Check the ribbon cables.
     
  3. Rulyman
    Offline

    Rulyman New Member

    Joined:
    Sep 6, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi, exactly the same thing happens to me. When I connect the battery, all the motors move, but when I turn on the emsiora, the right rear engine does not work. I have changed the engine and the ESC and that arm does not go but the others do. What could it be to order the piece? Thank you
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Joined:
    Sep 19, 2015
    Messages:
    5,691
    Likes Received:
    421
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +534 / 15
    Remove the Flight Controller and check that the ribbon cable is not cracked. Clean it with Isopropyl alcohol and try again.
     

Share This Page