Error flashing / beeping on start up

Discussion in 'Walkera F210 3D' started by madals, May 5, 2018.

  1. madals
    Offline

    madals New Member

    Joined:
    Dec 28, 2017
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    Ratings:
    +1 / 0
    Hi,

    Not flown for a while due to weather. Just tried to power up my F210 but unable to arm the drone. All transmitter switches are in correct positions.

    Error:
    Lights on the back:
    Left red light (constantly on)
    Right red light (flashing)
    All 3 right yellow lights (flashing)
    All 3 left yellow lights (off)

    It beeps for a while before stopping beeping, but light flashing continues.

    Was flying perfectly at the last flight. Tried looking online for error codes / can't seem to find anything?

     
  2. madals
    Offline

    madals New Member

    Joined:
    Dec 28, 2017
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    Ratings:
    +1 / 0
    Hi,

    Still not had any luck finding a cause or any information about the error. Any update or help would be appreciated.
     
  3. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    Have you checked that you have not bumped the Trims. They must be at 0.
     
  4. madals
    Offline

    madals New Member

    Joined:
    Dec 28, 2017
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    Ratings:
    +1 / 0
    Just turned it all on to check trims (which I had checked previously) and despite nothing changing at all since my last set of tests - all working fine now!

    Nothing changed on my end :S Any idea what the cause could be (tried multiple batteries on different days, only today magically fixed) as if a dodgy part would be good to get a spare!
     
  5. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    If you do not have Fixed ID set you only have about 3 seconds after switching on the TX to connect the battery to the drone. If you take longer the binding will fail.

    Cheers
     
  6. Gnjac0rp
    Offline

    Gnjac0rp New Member

    Joined:
    Apr 3, 2019
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I didnt realise how quick you had to be with the pairing, I have tried the TX then RX and I have also tried TX then RX but doesnt change the outcome. I will try being even quicker when turning both units on but as stupid as it may sound any tips on the procedure?
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    If you have all 3 yellow lights on one side flashing it means that you have either aileron or rudder sent from your TX. It will not arm if that is the case.

    If you have all trims set to zero then you must recalibrate the sticks in the System menu.

    Cheers
     

Share This Page