Drone F250 Losing Control after takeoff

Discussion in 'Walkera Runner 250 Pro' started by Antonio Cesar Camolezi, Mar 20, 2019.

  1. Antonio Cesar Camolezi
    Offline

    Antonio Cesar Camolezi New Member

    Joined:
    Nov 21, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 1
    Hi, my F250 is losing control after takeoff. I replaced the main board and the radio, but it continues to lose control. Does anyone know why this occurs? And how to solve this?

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,978
    Likes Received:
    441
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +566 / 16
    You need to be more specific on what originally happened to make you replace this parts, and what is exactly happening now.

    What do you mean by lose control is this just taking off is this random in a hover is this if you move a distance away.

    Please be more specific.
     
  3. Antonio Cesar Camolezi
    Offline

    Antonio Cesar Camolezi New Member

    Joined:
    Nov 21, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 1
    Ok, being more specific: There was a strong collision with my drone, was need changed only frame and camera. After this repair the aircraft began to lose control for a few seconds, some time later this problem increased. Even flying at a distance of 20 feet, in the best places, facing the aircraft, without leaving the place, the drone starts to fly uncontrolled after take off.
    I changed the Main Control Board (FCS-250) and the Receiver (DEVO-RX717) and updated the firmware but the problem continues.
    There are several reports of similar problems in this forum, but no answer or solution. Please help me.
    Thanks
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,978
    Likes Received:
    441
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +566 / 16
    Check that the ribbon cables FC and RX are not cracked and cleaned.

    Check that
    the rx antenna are routed away from the Carbon fibre and into the antenna holders correctly.

    There may be damage to the FC.

     

Share This Page