Devo 12s problem, maybe you can help

Discussion in 'Walkera Devention Radios' started by Mitchie, Jan 11, 2017.

  1. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    Hi All,
    I have a problem with my 12s (well, two actually...no, make that two and a question:D). The blue light on the 12s (indicates plugged in) never shuts off. To turn off the light, I have to pull the battery out. The battery indicator(original fw, that's the other problem) shows that the radio is plugged in even tho it's not, so it doesn't tell me the charge level on the radio. Could it be a physical switch on the TX USB plug that's causing it, or would there be a board that's fried and needs replacing? Otherwise, the radio appears to be working properly. That brings me to my other problem. I tried installing Deviation to the 12s, and it appeared to be working, but when I powered up the TX after the install, I had only 1 model and couldn't change anything so I know I got the library install wrong(I remember reading the post), but can't find the post that describes how to fix it. And has anyone here tried the Java Runtime app on a Mac to install Deviation on a 12s? I know on the 12s the windows install is different from all the others, so I'm a little leary on trying it. I really don't want to trash my radio.
    Sorry for the long post
    Mitch
     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,473
    Likes Received:
    212
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +276 / 9
    There must be a fault on the main board. There is no spare stock in Walkera. I have tried.

    The deviation install is easy.

    When you download the FW. You must install the Firmware and the Library included with the dfuse tool.

    Just make sure that you select the correct tab in Dfuse to burn FW and then change to burn Library.

    Once installed you need to format the USB disk that pops up when the TX is connected and then copy all the files (leave out the .bin and Zip files) to the USB disk.

    Then you should have it all working.

    It is a struggle to calibrate the screen once updated you will need to use the buttons to get to the screen calibration utility.

    Once you do that and get it working I will give you my new Library so you can access the new 3D transparent toggle buttons i created and I will also give you my transparent model Icons.

    I have also upgraded to the 4 in 1 module so it flys everything. I have done a professional level job by using proper header pins and making it all plug and play.

    I will be documenting it all on the Forum here and on the Deviation site when I complete.


    See below for some preview pic examples.

    IMG_1692.jpg IMG_1621.jpg IMG_1628.jpg IMG_1656.jpg IMG_1620.jpg
     
  3. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    Those look great! If you have the F110 & 210 that would be even better!

    As far as the blue light, It's weird. The last time it did this, I sent it in to Walkera out of warranty, they charged me about $10 to repair (they said they replaced memory) and $40 to ship it back. I was just hoping some hardware guru would know about it. I'll just have to keep an eye on power manually.

    Your instructions are in another order than the way I did it. I'll give it a go.

    Thanks for the tips, and looking forward to reporting my success!
    Mitch
     
  4. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    Well, can't report success :( I went from a fresh Devention install to the Deviation firmware ok, but when I went to install the library in the third tab it said it was already installed and the upgrade or verify action check box and buttons were grayed out. Ok I thought, and moved on to the reboot in USB mode, but it ignored the button press and rebooted into Devention??? I tried several times, but now when I try to turn on the TX without toggling anything, I get usb mode. Should I re install Devention FW and start over?
     
  5. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,473
    Likes Received:
    212
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +276 / 9
    I think you are falling into the newbie trap of using save rather than load on dfuse.

    You need to replace the files again with an new download, and when you select the .bin use load. not save.

    You have corrupted the deviation files by over writing them with the files off the radio.
     
  6. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    Sorry for all the newbie questions. I just want to get it straight. Should I format the USB drive first, then reinstall Devention? From there use the Dfuse tool to upgrade(not upload) dieviation-devo12-v5.0.0.dfu on the firmware tab. Then move to the Library tab, and load devo12-lib.dfu using the upgrade or verify file button, then shut down the radio. Turn on the radio while holding ENT to start in USB mode, then copy all the files outlined in the Deviation manual. When done, just turn off and turn on again to see the Deviation screen. If this is not right, feel free to call me a dunce and correct me :)
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,473
    Likes Received:
    212
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +276 / 9
    You download the Deviation FW for your Transmitter.

    Unzip The files.

    Read the PDF user manual. It explains step by step what to do.

    Section 2 Installation.

    Cheers
     
  8. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    Ok, looks like the only thing I did wrong during my original install was to calibrate the touch screen.....doh! Now it's installed and the touch screen is working. Now, all I have to do is get everything the way it's supposed to be. Do you have the model files online somewhere? I'd love to get this thing working. It's been out of action a while (I have an 8s on Deviation, so I was never in a rush. Now that it's working, I'd love to get everything on it. I know I can't use the models from the 8 in the 12, but worst case scenario I can manually transfer the models I have.
    Thanks for the help
     
  9. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,473
    Likes Received:
    212
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +276 / 9
    Yes you can. The models are identical in all Deviations supported radios. They are also all 12 channels. So a Devo 8 with Deviation FW is a 12 channel radio.

    Pretty cool Eh.

    Cheers

    Send me a PM so I don't forget and I will send you a new Library with heaps of new 3D transparent toggles to use and All the transparent 3D model Icons I have made to date.
     
  10. Mitchie
    Offline

    Mitchie Member

    Joined:
    May 1, 2016
    Messages:
    74
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +8 / 0
    I've been using the 8s to run 12 channel rx's for a while. And like you said, Pretty Cool! I want to thank you for your help! PM is on the way!
    Mitch
     

Share This Page