Devo 12S Deviation Upgrade Keep Failing

Discussion in 'Walkera Devention Radios' started by DanK, Oct 26, 2018.

  1. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Yes I upgraded the FW via Firmware tab then Library via the Library tab

    [​IMG]

    [​IMG]

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    That looks like an invalid file name.

    Load the library down again from the deviation site.
     
  3. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
     
  4. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Ok I just downloaded the latest Nightly Build "deviation-devo12-v5.0.0-7ad3a24" same thing. FW upgraded successfully but got error for Library
     
  5. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    Try this library I built it with more Icons for the main screen.
     

    Attached Files:

  6. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Thanks for the Library, I am still cant upgrade the library got same error.

    I restored the stock firmware but cant restore the Library. I think I destroyed my filesystem library because when switching to the firmware upgrade mode on my TX I don't see the Walkera splash screen anymore but a fuzzy screen.

    Also in System Menu > About

    Hardware Ver 1.0
    Software Ver 1.5A
    Library yyyyyyyyyyyyyyyyyy...

    Maybe hardware issue?
     
  7. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    I can only think that the EEPROM could be damaged where the library is stored.

    Can you take a video of the screen when you start the Library upgrade?
     
  8. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I finally fixed it by retouched on all the pins on the parallel flash chip :):):)

    Thank you so much for all your help
     
  9. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,551
    Likes Received:
    388
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +492 / 15
    Fantastic. Let me know if you need any help with Deviation.

    Cheers
     
  10. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Yes sure will, thanks in advanced.

    I am starting to install the 4 in 1 module on both the 12s and F7, I've also placed an order for the DFPlayer Mini MP3 Modules do you have any experience with this?
     

Share This Page