Devo 12S Deviation Upgrade Keep Failing

Discussion in 'Walkera Devention Radios' started by DanK, Oct 26, 2018.

  1. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hello,

    I am trying to upgrade my Devo 12s with Deviation 5.0.0 but it keeps failing. I followed both methods using Walkera Dfuse and Deviation Uploader without any luck.

    I tried the official release(deviation-devo12-v5.0.0.zip) as well as the nightly build(
    deviation-devo12-v5.0.0-b08efa8
    ), when I reboot the Tx, its stuck in USB mode. I can browse to the USB drive on my computer.

    When upgrade using the Deviation Uploader 0.8.0, I can see the progress bar goes 1/3 of the way then a windows popup "Copy Completed" but when I reboot my Tx it's stuck in the USB mode.

    [​IMG]

    I also tried using the Walkera Dfuse 2.31, the Firmware upgrade went fine but I keep getting the below error Upgrading the Library

    [​IMG]

    This error for Verify

    [​IMG]

    I have no problem restoring the stock Firmware 1.5A 100mw

    Anyone have any idea what is going on here? I really desperately needing helps with this

    Dan

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,320
    Likes Received:
    334
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +436 / 14
    You need to read the Installation instructions.

    Once you flash the firmware you need to copy the update files from your PC to the USB drive on your Transmitter (Not the ZIP or FW file but all the others). Then reboot the transmitter.

    Cheers
     
  3. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I've done that many times but it keep booting up into the USB mode for some reason I cant flash/upgrade the library

    Maybe there is a write protected somewhere? :confused:
     
  4. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,320
    Likes Received:
    334
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +436 / 14
    It's meant to only boot up into USB mode. This will give you a small USB drive on your PC. From memory you have to format the drive (FAT) and then copy over the contents from the Unzipped 5.0.0 FW without the zip and FW BIN over to this USB drive then restart the radio.

    It's in the installation guide.

    So you don't flash the library you copy it to the USB drive. With all the .INI files
     
  5. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Yes, I tried that as well. Flash the firmware, format the USB then copy the files into USB drive but still boot up into USB mode
     
  6. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,320
    Likes Received:
    334
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +436 / 14
    I suggest you read the installation instructions in detail and follow them. There has to be a step you are missing.

    Are you using the correct Tab in Dfuse?

    What is the date on your dfuse binary?

    Have you tried to put the Devention Library back?

    What version of Windows are you running?
     
    Last edited: Nov 5, 2018
  7. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I read the instruction many times actually and tried all the instructions suggested, read post from similar issue again no luck :-(

    Walkera Dfuse USB Upgrade Tools 2.31 8/10/2014, I even tried DfuSe v3.0.5

    I keep getting the bad state in machine firmware error when tried to flash the Library

    I am running Windows 10
     
  8. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,320
    Likes Received:
    334
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +436 / 14
    If you put the origin Library back in does the radio work OK?
     
  9. DanK
    Offline

    DanK New Member

    Joined:
    Oct 26, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Yes, I can restored the stock firmware 1.5A 100mw using both the Dfuse and Deviation Uploader without any issue and YES the TX worked

    That what I don't understand why I keep getting error with Devention 5.0
     
  10. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,320
    Likes Received:
    334
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +436 / 14
    Can you reload the deviation Library?

    Not the FW the Library? FW and Library are loaded in different process.
     

Share This Page