Can't get my Furious 215 to bind with DEVO7

Discussion in 'Walkera Furious 215' started by bullet, Jul 2, 2017.

  1. bullet
    Offline

    bullet New Member

    Joined:
    Jul 2, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    I can't seem to get my Devo 7 and Furious 215 to pair at all. When I plug in power I get a loud constant beep along with a flashing red light on the flight receiver. Any help would be greatly appreciated.

     
  2. GrabAdabAgoo
    Offline

    GrabAdabAgoo Member

    Joined:
    May 11, 2017
    Messages:
    40
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Hawaii, USA
    Ratings:
    +7 / 1
    Select a new model. turn off devo. turn on devo and it should auto find the 215.
    once that happens go in to fixid and right down what that code is, go back to your correct model named f215 turn off devo. turn on devo and go to fixid, make sure code matches the previous one you wrote down. set the fixid and now when you turn on it should auto find the quad.
     
    • Like Like x 1
    • Agree Agree x 1
    • Disagree Disagree x 1
  3. bullet
    Offline

    bullet New Member

    Joined:
    Jul 2, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    This worked! Thanks a lot!
     
  4. tdkflorida
    Offline

    tdkflorida Member

    Joined:
    Dec 8, 2016
    Messages:
    63
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Georgia (USA)
    Ratings:
    +3 / 0
    This didn't work for me. I selected a new model and it still constantly beeps.
     
    • Agree Agree x 1
  5. Rusty Nail
    Offline

    Rusty Nail New Member

    Joined:
    Sep 21, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 1
    First of all, drone battery off, take your DEVO, enter MODEL, navigate to RESET ALL and run the reset, turn off DEVO. Than tune on DEVO and it will auto bind with drone
     
    • Disagree Disagree x 1
  6. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,578
    Likes Received:
    391
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +504 / 15
    This will just force a fixed ID clear on the radio. As well as delete all your settings. If a Fixed ID exists on the Drone then this will not help until your clean the drone RX.

    The other issue is that the Devo defaults to CP Helicopter that outputs Pitch on Channel 6. That will screw up the Flight Mode settings on most drones.

    Just setting the Fixed ID to 0 on the radio should be sufficient. And cleaning the RX on the drone.
     
    • Disagree Disagree x 1
  7. Rusty Nail
    Offline

    Rusty Nail New Member

    Joined:
    Sep 21, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 1
    [​IMG]
    How to clean on the drone RX
     
  8. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,578
    Likes Received:
    391
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +504 / 15
    Hold Button on RX and apply power to the drone.
     
  9. Gnjac0rp
    Offline

    Gnjac0rp New Member

    Joined:
    Apr 3, 2019
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    None of that worked. All any of that did was just end up clearing the preinstalled settings...
     
  10. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,578
    Likes Received:
    391
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +504 / 15
    Did you reset the Devo radio? If you did it needs reconfiguring to the settings in the Quick Start guide.
     

Share This Page

Search tags for this page

walkera furious 215 mit devo7 binden