Brand new voyager3 rear landing skid and front landing skids

Discussion in 'Walkera Voyager 3' started by thcinaus, Mar 17, 2016.

  1. thcinaus
    Offline

    thcinaus New Member

    Joined:
    Mar 17, 2016
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Bell, Queensland, Australia, 4408
    Ratings:
    +2 / 0
    I have a brand new voyager3 and its never been flown the front landing skids are stuck in the down position and the rear fail to go down.
    has anyone else found this problem and how is it fixed.
    I am an electronics tech so mods are no problem
    but there should be a logical answer to this problem.

     
  2. thcinaus
    Offline

    thcinaus New Member

    Joined:
    Mar 17, 2016
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Bell, Queensland, Australia, 4408
    Ratings:
    +2 / 0
    Problem solved. I found excessive heat coming from the electrolytic capacitor near the rear worm drive plug on the main board. so I disconnected the rear worm drive and the front landing gear responded as normal. A test on this unit found it had shorted out and was causing excessive current drain on the whole power supply. I will ask walkera to replace this piece under warranty as the piece is obviously faulty from new. I would recommend to other users to fuse these motors or add mini circuit breakers so if there is a short the system is protected from failure in the future.
     
  3. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    4,965
    Likes Received:
    302
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +394 / 13
    When you get your replacement worm drive I assume that you will be fusing or adding cct breaker as per your post?

    If you could document the procedure with some pictures and post I will turn it into a sticky for members.

    Cheers
     
  4. thcinaus
    Offline

    thcinaus New Member

    Joined:
    Mar 17, 2016
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Bell, Queensland, Australia, 4408
    Ratings:
    +2 / 0
    I have decided to put a resister in line to reduce the speed of the rear landing gear I have not flown yet but have gone through 2 worm servos that failed because they jam get hot and fail stopping the gear from working and having trouble landing
     

Share This Page

Search tags for this page

walkera voyager 3 rear landing wont go down