Binding the furiuos 215 or replacing the reciever issues!!!!!!!

Discussion in 'Walkera Help!' started by MikeBlair, Jun 18, 2017 at 2:14 PM.

  1. MikeBlair
    Offline

    MikeBlair New Member

    Joined:
    Jun 16, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    So, the other day I had to replace some motors on my furious 215. While doing this, I may have accidently pressed the small white button that's on the side of the stock receiver. Needless to say, now I cant get the Devo 7 to connect with the drone. I have tried doing the whole fixed ID thing several times and in several suggested ways. Still, nothing seems to be working. When I power up the drone it just continues to beep, beep, beep at me and the red LED on the PBD (at least that's what I think the top board is called) continues to flash in a slow blink. Does anyone know what I can try to fix this issue???? Should I just try to put a different receiver in the drone ??? Is that even possible?? and if so how. thanks.
     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    3,803
    Likes Received:
    233
    Trophy Points:
    63
    Location:
    Sydney, Australia
    Ratings:
    +305 / 10
    Turn off Fixed ID in the radio. Press the button on the RX again and try again.

    You can only activate Fixed ID after a successful bind while it is still bound.

    Your video shows that Fixed ID is still set on your TX.
     

Share This Page