Backward drift

Discussion in 'Walkera Rodeo 110' started by Ganappetto, Aug 29, 2017.

  1. Ganappetto
    Offline

    Ganappetto New Member

    Joined:
    Aug 29, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    hello to everybody
    Today I purchase my new rodeo 110 but just I put on battery and bind radio I try to fly but drone go backward!!
    Try everything (trim, check props direction etc) nothing to do, it goes backward!!!
    Go,back to seller who tells me that's normal, must be calibrated to zero first time.
    This is my second 110, first doesn't needs everything, why?
    Something wrong with this new One?
    Anybody got same issue?
    How can I get a solution?
    Thanx

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    5,374
    Likes Received:
    354
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +456 / 14
    This is a common problem with the rodeo 110.

    I have been trying to come up with a repeatable solution but I am not there yet.

    The rodeo has a separate card where the IMU is located. It has moved in shipping or manufacture and now is way out of calibration. Unfortunately this cannot be recalibrated via Software.

    Send it back. You will invalidate your warranty of you open it up.

    Hopefully I will have a repeatable fix some time soon. It cannot be done by tuning or setting via Cleanflight. I have tried them all.

    It will need to be a physical Fix / Repair.
     

Share This Page