350 pro

Discussion in 'Walkera Help!' started by Gary Garthwaite, May 6, 2020.

  1. Gary Garthwaite
    Offline

    Gary Garthwaite New Member

    Joined:
    May 5, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi all got qrx350 pro of my father wen I went to lift of after doing calibration all went to plan then as I give it throttle it lifts of one side only so I checked all props spinning correct way props were not right sorted this then it’s started lifting of other side why is this everything is correct all doing the correct way but left side lifts up and right side stays on the ground and gonna flip I am gonna try starting from scratch again anyone else had this problem and figured it out please am gutted please help people

     
  2. bjr981s
    Offline

    bjr981s Moderator Staff Member

    Top Poster Of Month

    Joined:
    Sep 19, 2015
    Messages:
    6,037
    Likes Received:
    442
    Trophy Points:
    83
    Location:
    Sydney, Australia
    Ratings:
    +567 / 16
    Make sure you get the props correct.

    Check that they spin "in" Front and Rear to the nose tail axis.

    Front Left Clockwise, Front Right Counter Clockwise.
    Back left counter Clockwise, Back right Clockwise.

    Make sure that the motors spin in those directions as well.

    Cheers
     
  3. Gary Garthwaite
    Offline

    Gary Garthwaite New Member

    Joined:
    May 5, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Spinning the correct way but seems to be a very slow start on right side to left side ones side starts then other but only just out so something is t right just want it gone now and gonna get something else got a Devo f12e with it and 2 battery’s cheers anyway
     

Share This Page